Skip to content

Liii STEM 文本模式完全指南 ​

Liii STEM 的文本模式是默认编辑状态,用于撰写正文,标题,段落,表格,图片等常规内容。与 LaTeX\LaTeX 需要编写源码再编译不同,Liii STEM 采用所见即所得的编辑方式,所有排版效果实时呈现。如果您是 LaTeX\LaTeX 专家,建议先阅读 写给 LaTeX 用户的 Liii STEM 教程。

本文全面介绍文本模式下的核心操作,帮助您从零开始构建专业文档。

0 如何判断是否处于文本模式 ​

观察焦点工具栏即可判断当前模式:

  • 文本模式:焦点工具栏显示文本排版相关按钮(粗体,斜体,颜色,对齐等)
  • 数学模式:焦点工具栏显示数学符号和公式编辑按钮

样式设置界面

上图展示了三种模式下的焦点工具栏对比。当工具栏呈现文本样式按钮(如粗体,斜体,下划线等)时,即表示当前处于文本模式。

1 内容标记与字体设置 ​

操作方式:

我们以粗体为例, 有两种操作方式:

  • 先选后加:选中文字后按 Ctrl+b (或者 \textbf 后回车, 或模式工具栏点击) 即可应用粗体
  • 先加后写:按 Ctrl+b (或者 \textbf 后回车, 或模式工具栏点击) 进入粗体环境,输入的文字自动为粗体,按 → 退出

后文不再赘述操作方式。

1.1 加粗,斜体,强调 ​

样式LaTeX\LaTeX快捷键 / 命令效果示例
粗体\textbf{...}Ctrl/Cmd+b 或 \textbf粗体文本
斜体\textit{...}Ctrl/Cmd+i 或 \textit斜体文本
强调\emph{...}\emph强调文本

提示:\emph的字体取决于模板,大部分模板里都是斜体。

中文字体:

Liii STEM 原生支持中文排版在焦点工具栏即可选择宋体,黑体,楷体,仿宋等中文字体。关于字体设置的完整介绍,详见 你的第一篇 Liii STEM 文档。

提示:在 LaTeX\LaTeX 中,中文字体设置通常需要在导言区配置 ctex 或 xeCJK 宏包。在 Liii STEM 中,中文支持是内置的,打开即用。

事实上,本文的全部操作均无需导入任何宏包,后文不再赘述。

1.2 颜色与字体大小 ​

文本颜色: 在焦点工具栏选择调色盘调色盘按钮,后选择颜色(或使用 \red,\blue,\yellow,\pink,\cyan 等命令)。

字体大小: 全局的字体大小可以在焦点工具栏设置。局部的字体大小可以用下

大小LaTeX\LaTeXLiii STEM 操作
极小\tiny焦点工具栏选择
小\small焦点工具栏选择
正常\normalsize默认
大\large焦点工具栏选择
极大\huge焦点工具栏选择

1.3 删除线, 高亮,下划线 ​

样式快捷键 / 命令效果示例
删除线- - Tab Tab 或模式工具栏这是删除线文本
下划线- - Tab 或模式工具栏下划线文本
高亮模式工具栏高亮文本

1.4 正文字体类型 ​

Liii STEM 支持多种字体族,可在焦点工具栏或模式工具栏中切换:

字体族LaTeX\LaTeXLiii STEM 操作
罗马体(衬线)\textrm{...}默认字体
无衬线体\textsf{...}\textsf
等宽体\texttt{...}\tt
手写体\textsc{...}\textsc

提示:在 LaTeX\LaTeX 数学模式中,将字母排成正体算子需使用 \mathrm 命令(如 dx\mathrm{d}x 中的 d\mathrm{d})。在 Liii STEM 中,单字母按 Tab 即可切换为算子,多字母自动拼接为算子。详见 数学模式完全指南 4.3。

关于数学字体(如 \mathbb,\mathcal,\mathfrak 等)详见 数学模式完全指南 4.2。

2 标题,摘要,章节和目录 ​

2.1 文档标题与摘要 ​

在 Liii STEM 中,文档的标题和摘要通过专门的标题环境和摘要环境来创建。

插入标题:

  1. 点击 插入 -> 章节 -> 标题 进入标题环境
  2. 在标题环境的焦点工具栏点击 ⊕\oplus 可选择插入 副标题,作者,邮箱,机构, 日期 等子环境。

提示: Liii STEM 的标题环境是一个拥有许多子环境的特殊环境,不支持 \title 命令直接插入。

插入摘要:

  • 点击 插入 -> 章节 -> 摘要 进入摘要环境或输入 \abstract 后回车,创建摘要环境。

请不要将摘要环境嵌套入标题环境内!按方向键可以退出标题环境,通过焦点工具栏可以判断当前所处环境。

2.2 章节层级 ​

Liii STEM 提供完善的章节层级系统,并支持自动编号和交叉引用。

层级快捷键命令
章Alt+0\chapter
节Alt+1\section
子节Alt+2\subsection
子子节Alt+3\subsubsection
段落Alt+4\paragraph
子段落Alt+5\subparagraph
附录Alt+6\appendix

编号控制:

  • 自动编号:默认开启,章节会自动编号(如「1 引言」「1.1 背景」),如果需要取消则在焦点工具栏点击 123 按钮或使用快捷键 Ctrl + #。
  • 以章节号为前缀:将光标放在节环境中,点击焦点工具栏的扳手键,勾选以章节号为前缀,编号会自动带上章节前缀(如「1.1 引言」 「1.1.1 背景」))

章和节都是独立的环境,不能嵌套使用。

章节的文本语言随排版语言变动,可退出章节环境后在焦点工具栏设置排版语言。

2.3 目录 ​

Liii STEM 可以为您自动生成目录!请永远也不要手动编辑目录!

插入目录:

  • 输入 \tableofcontents 后回车,或点击 插入 → 自动 → 目录

菜单栏点击 插入 → 自动 后还可以选择插入 图目录, 表目录 等。请都尝试一下!

当章节标题发生变更后,按 Ctrl/Cmd+Shift+r 刷新目录。 或者菜单栏点击 文档 -> 更新 -> 全部。

点击焦点工具栏的扳手按钮,可以修改目录的文本(例如改成预览)。还可以决定是否显示章节编号 (默认不显示,即 Sectional Short Style 选项开启)。

导出 PDF 后,目录项可点击跳转到对应章节。

3 列表 ​

3.1 无序列表与有序列表 ​

无序列表使用符号作为标记:

  • 输入 + 后按 Tab(或 + 空格),或输入 \itemize 后回车

有序列表使用数字或字母作为标记:

  • 输入 1 . 后按 Tab(或 1 . 空格),或输入 \enumerate 后回车

按 Enter 创建新项。 利用 Tab 和 Shift + Tab 可以控制缩进。

无序列表符号样式(可在焦点工具栏设置):

样式符号
圆点•
短横线–
星号*
箭头→

有序列表编号样式(可在焦点工具栏设置):

样式示例
阿拉伯数字1, 2, 3
小写字母a, b, c
大写字母A, B, C
罗马数字i, ii, iii
大写罗马数字I, II, III

符号和编号的样式也可以 按 Alt + Shift + ↓ 循环切换。详见 高效编辑指南。

3.2 描述列表 ​

描述列表用于术语解释,每项由术语和定义组成。

  • 输入 Alt + D 插入描述列表。默认光标处于术语位置,术语会自动加粗,方向键可移动至定义部分。

示例:

LaTeX.      一种基于 TeX 的文档排版系统
Liii STEM.  下一代科学写作平台

提示:描述列表特别适合编写词汇表,API 文档或术语定义。

对描述列表的缩进等操作与下小节描述等同。

3.3 更多列表操作 ​

Liii STEM 提供了许多对列表的快捷操作。整理如下:

操作快捷键
增加层级 (缩进)Tab
减少层级 (反缩进)Shift+Tab
切换有序/无序焦点工具栏 123 按钮 或 Ctrl + # 快捷键
更改编号样式焦点工具栏选择 或 Alt + Shift + ↓
向上向下添加项Alt+↑ / ↓
回到上一项Alt+Backspace
删除当前项Alt+Delete(macOS:Alt+Fn+Backspace)

4 语义块 (定义定理环境等) ​

语义块(Enunciation)是数学和科技写作中用于标记定理,引理,推论等结构化内容的环境。

4.1 常见语义块的插入 ​

插入语义块:

环境命令菜单路径
定理\theorem插入 → 语义块 → 定理
命题\proposition插入 → 语义块 → 命题
引理\lemma插入 → 语义块 → 引理
推论\corollary插入 → 语义块 → 推论
证明\proof插入 → 语义块 → 证明
公理\axiom插入 → 语义块 → 公理
假设\assumption插入 → 语义块 → 假设
定义\definition插入 → 语义块 → 定义
记号\notation插入 → 语义块 → 记号
约定\convention插入 → 语义块 → 约定
注记\remark插入 → 语义块 → 注记
笔记\note插入 → 语义块 → 笔记
示例\example插入 → 语义块 → 示例
警告\warning插入 → 语义块 → 警告
致谢\acknowledgment插入 → 语义块 → 致谢
问题\question插入 → 语义块 → 问题
答案\answer插入 → 语义块 → 答案
练习\exercise插入 → 语义块 → 练习
习题\problem插入 → 语义块 → 习题
解答\solution插入 → 语义块 → 解答

也可以在模式工具栏点击 语义块 图标插入语义块。

将光标置于语义块中,按 Alt+Shift+↓ 可在各种语义块变体之间循环切换。详见 高效编辑指南。

提示:不同语义块的默认排版规则有所区别,因此不建议嵌套使用。例如英文模板下,定理,引理,推论等环境的内容通常为斜体,而定义,注记等环境的内容为正体。此外,练习(Exercise),习题(Problem),解答(Solution)等内容会自动缩进,而问题(Question)和答案(Answer)则不会缩进。

4.2 语义块设置 ​

在焦点工具栏中,可以调整语义块的各种属性:

  • 编号:焦点工具栏点击 123 或者 Ctrl + # 快捷键可以选择是否编号。
  • 以章节号为前缀:编号自动带上章节前缀(如 定理 3.1)。
  • 定理加框:为定理环境添加边框 (也可以用 \framed 手动加框)。

4.3 选读:自定义语义块 ​

如果内置的语义块不能满足需求,您可以在导言区自定义新的语义块。更多关于宏定义和导言区的用法,请参阅 创建宏命令。

点击 工具 → 宏命令 → 编辑导言(Ctrl+Shift+p)进入导言区,输入 \new-theorem 后回车,即可创建新的语义块:

命令样式说明
\new-theorem斜体(theorem-like)类似定理,引理,推论的排版样式
\new-remark正体(remark-like)类似定义,注记,示例的排版样式
\new-exercise缩进(exercise-like)类似练习题目,解答的排版样式

我们以自定义一个 Hypothesis 语义块为例,在导言区输入 \new-theorem回车后会出现如下结构:

<new-theorem|COMMAND|NAME>

填写

<new-theorem|hyp|Hypothesis>

完成后再次点击 工具 → 宏命令 → 编辑导言(Ctrl+Shift+p)返回正文,此后即可通过 \hyp 后回车插入自定义的 Hypothesis 语义块。自定义语义块支持自动编号和交叉引用,用法与内置语义块完全一致。

5 参考文献,引用与超链接 ​

5.1 参考文献 ​

Liii STEM 支持通过 BibTeX .bib 文件管理参考文献。点击 插入 → 自动 → 参考文献 导入 .bib 文件后,输入 \cite 后回车即可插入引用,按 Ctrl/Cmd+Shift+r 刷新引用编号和参考文献列表。

.bib 文件的格式和样式设置,请参阅 参考文献插入指南。

5.2 超链接 ​

Liii STEM 内置超链接支持,无需额外配置。输入 \hlink 后回车 (或者在菜单栏点击 插入->链接->超链接) 可插入外部链接(指向网页),在对话框中填入 URL 和显示文本后回车即可。例如

xml
<hlink|Baidu|baidu.com>>

Ctrl/Cmd + 鼠标左键点击 可以快速跳转至超链接页面。

超链接也支持文档内跳转,填写相对路径即可,例如

<hlink|第一章|./chapter/chap_01.tmu>>。

已编辑好的超链接可以用方向键进入环境后在焦点工具栏修改目标地址。

5.3 双向引用 ​

如果您想在文章内做双向引用,例如 节 1, 定理 3 之类的,此小节的教程便可以帮到您。对于任何需要被双向引用的环境,我们都需要为这个环境打一个标签,然后在需要的地方引用这个标签。

事实上,所有在 Liii STEM 内可以用 焦点工具栏的 123 (或 Ctrl + #)编号的环境都可以被双向引用,甚至包括有序列表。

手动输入「如定理 3.1 或图 2」在编号变动后需要逐一修改,且无法预览内容或跳转到目标位置。

将光标放在需要被引用的环境中,在菜单栏选择 插入->链接->标签 或者按 Ctrl+!(或输入 \label)创建标签。建议遵循以下命名前缀:

类型前缀示例
公式eq:eq:euler-identity
定理thm:thm:fermat
命题prop:prop:main-result
引理lem:lem:convergence
推论cor:cor:limit
定义def:def:group
示例ex:ex:counter-example
注记rem:rem:observation
算法alg:alg:dijkstra
图表fig:fig:result
表格tab:tab:comparison
章节sec:sec:intro
列表enum:enum:requirements

在需要引用的地方按 在菜单栏选择 插入->链接->参考 或 使用快捷键 Ctrl+?(或输入 \reference),输入刚刚设定的标签名称后回车即可插入引用,支持 Tab 自动补全。

将鼠标悬停在引用编号上可实时预览被引用的内容,使用 Ctrl/Cmd+[ 或 ] 可在引用和目标之间跳转。更详细的交叉引用和 smart-ref 用法请参阅 双向链接和引用。

6 图片与表格 ​

6.1 OCR 识别 ​

Liii STEM 支持将剪贴板中的图片通过 OCR 识别为可编辑内容。将需要识别的内容截图保存到剪贴板后,在文档中按 Ctrl+Shift+v(macOS:Command+Shift+v),系统会自动识别文字、公式和图片,并排版为可编辑内容。

将要识别的图片直接拖入进 Liii STEM,然后将光标悬浮在图片上,图片上方会显示 OCR 按钮,点击后即可识别 。

macOS的系统截图快捷键 Cmd + $ 拖拽进来的图片无法 OCR 识别,因为这样截图不会进入 macOS 的剪贴板。使用 Cmd + Option + $ 截利用飞书,微信等软件提供的截图工具可以避免此问题。

更详细的 OCR 和魔法粘贴用法请参阅 魔法粘贴快速入门。

6.2 图片插入 ​

Liii STEM 支持直接插入图片文件,也支持插入带题注的图片环境。直接插入图片时,点击模式工具栏的 插入图片 图标,或者点击菜单栏的 插入 -> 图片 -> 插入图片,或者直接将您想插入的图片拖拽进 Liii STEM 均可!

Liii STEM 支持 .png、.jpg、.svg、.pdf 等图片格式。

如需插入带题注(即带字幕和数字序号的)的图片环境(推荐用于论文),可以输入 \big-figure 后回车,或点击模式工具栏的 大图片及题注,或点击菜单栏的 插入 -> 图片 -> 大图片及题注即可。

在焦点工具栏中可调整图片的各项属性:

功能操作
调整大小拖动四角或焦点工具栏精确设置
序号焦点工具栏可选择是否添加序号以及序号是否以章节为前缀
对齐方式左对齐/居中/右对齐 (或光标悬浮在图片上选取)

提示:链接插入图片类似于 LaTeX\LaTeX 的引用方式,仅在文档中保存图片路径。您可以随时通过焦点工具栏的 ↑ 键将其转换为嵌入。

更详细的图片操作请参阅 图片和表格编辑进阶。

6.3 表格插入 ​

菜单栏点击 插入->表格->标准无框表格 或者 按 Alt+t(或 Option+t)可插入 1×11 \times 1 的无框表格结构。

按 Tab 或 Alt+Shift+↓ 可切换表格变体,例如有框表格等,详见 高效编辑指南。

如需插入带题注(即带字幕和数字序号的)的表格环境(推荐用于论文),可以输入 \big-table 后回车,或点击菜单栏的 插入 -> 图片 -> 大表格即可。

该快捷键在文本模式下插入表格,在数学模式下则插入矩阵、行列式等结构。请参阅 数学模式完全指南 3.4: 矩阵行列式与分段函数。

表格插入后,可以在焦点工具栏设置,也可以通过如下快捷键扩展:

操作快捷键
增加列Alt+→
增加行Alt+↓
删除上行/列Alt+Backspace
删除当前行/列Alt+ Delete (macOS: Option+Fn+Backspace)
切换变体Alt+Shift+↓

在焦点工具栏中也可调整表格的各项属性:

属性操作
单元格大小直接拖动
背景色和边框焦点工具栏设置
对齐方式单元格内容左对齐/居中/右对齐
边框样式有框线、无框线、仅横向线等
题注位置设置题注(字幕)显示在表格上方或下方

更详细的表格操作请参阅 图片和表格编辑进阶。

7 算法与代码 ​

Liii STEM 中与代码相关的内容分为三种环境,分别适用于不同的场景:

环境适用场景章节
代码块展示程序源码,保留语法高亮与缩进7.1 代码块
算法环境排版伪代码,自动渲染关键字与结构7.2 算法环境
会话在文档内直接执行代码并嵌入结果7.3 会话

7.1 代码块 ​

Liii STEM 支持插入代码块用于展示程序代码。输入 \code 后回车插入纯文本代码块,或点击 插入 → 程序 → 代码块 选择具体语言。插入后在焦点工具栏可切换编程语言,支持 Python、Gnuplot、Maxima、C/C++、Java、Shell/Bash、JavaScript、Julia、SQL、Scheme 等。代码块会自动保留语法高亮与缩进。

如需在段落中插入行内代码,点击 插入 → 程序 → 行内代码 即可。

如果需要显示行号只需要在 \listing 环境内插入代码块即可。

7.2 算法环境 ​

对于需要展示伪代码的场景,输入 \algorithm 后回车,或点击 插入 → 程序 → 算法 即可插入算法环境。

在算法环境中,通过以下命令构建伪代码结构:

结构命令说明
语句\algo-state普通算法步骤
输入条件\algo-requireRequire
输出条件\algo-ensureEnsure
返回\algo-returnReturn
打印\algo-printPrint
注释\algo-comment注释(斜体)
条件判断\algo-ifIf 条件
否则如果\algo-else-ifElse If
否则\algo-elseElse
While 循环\algo-whileWhile 循环
For 循环\algo-forFor 循环
重复直到\algo-repeatRepeat-Until
过程\algo-procedureProcedure
函数\algo-functionFunction
调用\algo-call函数调用
逻辑与/或/非\algo-and / \algo-or / \algo-not逻辑运算符

此外还支持 \algo-for-all、\algo-for-each、\algo-loop、\algo-begin、\algo-inputs、\algo-outputs、\algo-data、\algo-result、\algo-xor、\algo-to、\algo-true、\algo-false、\algo-globals 等命令。

焦点工具栏可选择居中排版, 是否编号,以及修改算法标题。

如果需要修改 \algo-ensure 的文本(例如改成 Input),只需在 \algo-ensure 环境里点击焦点工具栏的扳手按钮,选择 编辑宏 即可修改文本。

7.3 会话 ​

会话(Session)是与代码块、算法环境不同层级的环境,用于在文档中直接执行代码并嵌入结果。点击 插入 → 会话 选择语言即可插入。

会话的输入不限于代码,也可以是文本或数学公式甚至图片;执行后的输出同样可以是文本、数学公式、图表或表格。这里仅以可执行代码会话举例。

在会话中输入内容后,按 Enter 或点击工具栏的运行按钮即可执行,结果会自动嵌入文档。点击会话外的区域退出交互,结果将永久保留。其交互方式与 Jupyter Notebook 类似,在代码单元旁直接查看输出。

Liii STEM 支持 Python、Gnuplot、Maxima、Scheme、Elvish、Goldfish Scheme 等会话。其中 Python 会话支持 Matplotlib 2D/3D 图渲染、SymPy 公式输出和 Pandas 表格渲染。更详细的用法请参阅 Python 插件 和 Gnuplot 绘图。

8 批注,脚注与边注 ​

8.1 脚注 ​

脚注是文档中常用的补充说明方式。将光标放在需要添加脚注的正文位置,按 Ctrl+Shift+f(Windows/Linux)或输入 \footnote 后回车,在页面底部的脚注区域输入内容即可。脚注会自动编号并按顺序生成,始终出现在引用所在的页面底部。在焦点工具栏可调整脚注编号样式(数字、星号、字母等),导出 PDF 时脚注位置与样式均会得到保留。

8.2 边注 ​

边注(Margin Note)出现在页面边缘,适合添加简短的备注或引用。点击 插入 → 注记 → 边注,或输入 \marginal-note 后回车即可插入。插入后会出现 <marginal-note|normal|c|输入正文后回车> 结构,在右侧输入正文后按 Enter 确认。如需修改边注内容,将光标置于 tag 右侧(见8.3的图)按 Backspace 即可编辑。

8.3 批注 ​

Liii STEM 支持批注功能,便于协作审阅和添加备注。批注功能需先启用宏包:点击 插入 → 注记 → 展开的的批注 (或者 Ctrl/Cmd + /),即可插入一个批注,同时菜单栏会出现「批注」菜单项。在批注框中输入内容(支持文字、公式、图片等)。

批注可以在焦点工具栏选择被折叠,折叠后的批注会有一个 tag(导出 PDF 后会消失),将光标放在标记右侧(见上图)可以预览批注。

批注展开与折叠效果

批注操作整理如下:

操作快捷键说明
插入Ctrl/Cmd+/在当前位置添加批注
展开/折叠Alt+Shift+↓展开或折叠批注
移动Ctrl/Cmd+[ / ]在上一个/下一个批注间移动
删除Backspace移除批注

在焦点工具栏可设置作者名称和背景色,默认作者名为电脑用户名,不同作者的批注用不同颜色区分。批注不会影响正文的排版和分页,导出 PDF 时可选择是否包含批注(适合审稿后导出清洁版本)。

9 后续阅读 ​

需要一份完整的快捷键速查表?请参阅 Liii STEM 的键盘快捷键。